Focado na segurança, WordPress 5.2 está entre nós

O WordPress 5.2 já está entre nós. Como previsto, a atualização começou a ser solta nesta terça-feira. O foco de “Jaco” – homenagem ao baixista de jazz Jaco Pistorious – é numa coisa que eu gostaria muito de alfinetar a minha antiga hospedagem: o de consertar os sites e saber onde as coisas estão dando errado. É a ferramenta de Diagnóstico (ver Ferramentas > Diagnóstico).

Essa ferramenta ajuda muito na questão de depurar e resolver erros. Aqui mostramos exemplos de dois sites desenvolvidos pela 612 Comunicação onde temos erros a resolver, e onde os erros estão resolvidos.

A atualização também facilita muito a vida de quem resolve os problemas mais críticos da plataforma, com uma maneira de entrada no modo de restauração – pausando plugins e temas que causem erros – bem como um melhor tratamento da temida “tela branca da morte”.

A nova atualização traz ainda 13 novos ícones no painel, verificação de compatibilidade com plugins, sendo essa baseada no PHP. Como dito, a partir de agora, a versão mínima de PHP recomendada para o WordPress 5.2. é a 5.6.30, e sites abaixo disso só vão receber a atualização se suas hospedagens tiverem o PHP atualizado – do contrário nem notificação vão receber. Quanto a verificação de plugins, se um deles necessitar de uma versão mais recente do PHP do que a que é utilizada, o WordPress não permitirá a ativação, prevenindo potenciais erros de compatibilidade.

Deixe uma resposta